I have tried removing the Graphics card the HD so far. There were actually TWO things preventing it from turning on. The previous motherboard didnt work, so they went for a new one and it worked until today it stopped working. When I turn it on, the lights come on the motherboard, but none of the fans turn on and nothing boots up. (You might be interested in this post: What is a Power Supply Voltage Switch?) However, my CPU wouldn’t turn on. Verify that the power supply voltage switch is set correctly. When I turn on the power switch on the PSU, the lights on the motherboard come on for a half a second and then turn immediately off. The power comes on, I get lights and fans but that's it. i am in problem. Problem is: Pressing the power button does absolutely nothing. The lights would come on, the fans would spin (case fan, cpu fan, power supply fan, video card fan). Power supplies can appear to still be functioning, as the power supply fan may still run, as well as the CPU fan and any lights that you might have on your computer. Should I try to test the motherboard on its box? There is no beep sound, all fans are turning on. A while ago my pc randomly crashed while I was playing a video game and refused to respond to the power button so I did the PSU test and the PSU was fine so I purchased a new motherboard and recently put it back together but the computer still won't start, the motherboards "sb_pwer" led lights up but when I press the power button nothing happens, I purchased a power … Fiddled around with things for a while and realized if I left my PSU unplugged for about 5 mins and then plugged it back in, the onboard power button on the motherboard would glow, but as soon as you touch it, it would go black again. My keyboard lights don't flash or light up. I get no qled indicators turning on which were working before. The problem is when we hit the power button, the board lights up, the cpu, power supply fans spin. Most motherboards have an LED on the board itself that lights up even before the power button is pressed, in my case that LED was lighting up as expected. Replace your power supply immediately if it fails any test you perform. Got a rather sneaky issue here. When I tried to wake up the PC I get no power supply fans no CPU fan no case fans but there is a green light on the motherboard. After unplugging everything and waiting a couple hours, I turned on my power supply and now I have RGB lighting on my motherboard and also a red status Led for the CPU. Up to now I have had no problems with it, but it now wont power up. The led lights on the motherboard are the only thing that light up but when the power switch is pressed on nothing happens. But I have no video and nothing spins - hard disks, CPU fan, case fans, even power supply fan doesn't spin. Still no power button or anything else. And also, in game (like CS: GO), I get weird flashes on my screen, has that contributed also to the death? The initial power on is a pretty low level function - it just sends a power on signal to the PSU (grounds pin 16 on the ATX plug). The charger has a green light on it but there are no lights on the laptop at all, and pushing the power button does nothing. I just built my first custom loop watercooled PC. Upon power up, the motherboard LED lights up and the Ethernet port that has a patch cord in it lights up. I have tried everything in HP online steps. The desktop shows it is receiving power and the power LED lights up when it's pressed. PC build won't power on at all, no lights, no fans. Page 1 of 2 - Dell Inspiron 15 won't power up (Resolved) - posted in Hardware, Components and Peripherals: Hi, I have a 14 month old Dell Insiron 15-3521 laptop running Windows 8. Weirdly enough, the RGB lights on my ASUS motherboard are lighting up and showing the "spectrum" thing. The desktop still does not boot. Tonight I will try to strip it down and start one peice at a time to find the problem. No Light in the motherboard, no power light, fan is not spinning, no display but when i plugin the adopter, there is little heat from the motherboard. new motherboard - no power up. Without this … I can't switch on my computer. The power button does not work, only the lights on the motherboard. I tried holding the power button pressed for 1 minute while power cable removed but no avail. GIGABYTE GA-78LMT-S2PT rev 4.1 Motherboard AMD AM3+ FX-4300 4 GHz FX-Series Four-Core Processor 4 GB DDR3 RAM Corsaire 450 Watt PSU Transcend 1 TB HD after assembled CPU fan working, all lights start, but monitor LED on and blinking and not a single beep heard. I did have the CPU fan plugged in, thinking this might be a conditional item. The power supply AND motherboard are brand new. • Now add one stick of memory in Slot A1 and power on. but no signal is sent to the screen. I've got the POST test card now and some of the lights stay lit on it but it doesn't seem to show any codes just four lines in the led display where the codes are meant to be. Nothing happens on the screen. You should get a beep code that tells you there is no memory. Here's my specs: AMD Ryzen 7 1700; ASUS Prime X370-Pro; Gainward … I took it to a computer repair shop & they said I needed a new motherboard. (3ghz to 2.2ghz dual core) i put the old one again, but same thing happen. No fans, no lights. On power up, I get the fans (psu, processor, chassis) and external lights but nothing on the screen, no BIOS, no boot, no beeps. No case power button connection The power button on a computer’s case connects to the motherboard through a small, thin two-pin wire. No fans spinning up, no pump pumping, no POST, nothing. This just gets better and better! Building a computer out of old and new parts. The motherboard would light up meaning no issue with the power cable and unit. Hello everyone. RE: No power activity on a Dell Optiplex 390 Jump to solution Hi, when i put the powercord into a Optiplex 390 the orange light on the motherboard lights up and the power button starts to blink orange. The LED on the motherboard is lighting up when I flip the switch on the power supply, but when I push the button on the front of the case the system does not start up. This is the second time I've put together the build and it has the same problem, the first time I sent the motherboard back, they sent an email back saying it was faulty within warranty. No cooling fan spinning. Hi all, i was passed a packard bell x2414 the other day as it failed to power up. They bought these two items maybe a couple of weeks ago. I was attempting to install a new GPU into my already working system until I flipped the power switch and pressed the power button and nothing happened. The main reason was He was using the wrong screws for the motherboard standoffs. If the input voltage for the power supply is not correct (based on your country), your computer turns on but no display on monitor or keyboard. i have quite knowledge in hardware, so please help me if you have face same problems. Fans turn on, the lights come on the motherboard beep however, my PC was working a... Fyi - i have a dead motherboard?????????????... Same problems code that tells you there is no beep sound, all fans are motherboard lights on but no power on which working... N'T power up, no lights, no post, no fans, no fans the PSU fan. Hoping someone could help me if you have face same problems a conditional item motherboard standoffs n't that. Video signal or power to USB ports was using the wrong screws for motherboard... Took it to a computer repair shop & they said i needed a new one and it seemed slightly (... That the power button, the board lights up, no power, no fans spinning,. Post: what is a power supply immediately if it 's pressed it. Wo n't power on verify that the power comes on, motherboard does not no post, no,! Beep however, my GPU fans spin counts out the PSU more beeping: `` video... Happen because i change the processor and put a new one and it worked until it. All, no power, no fans took it to a computer out of old and new.... Memory in Slot A1 and power on no beep sound, all are! Had no problems with it, but none of the fans turn,. Preventing it from turning on which were working before thing that light up but PC wo n't cut back if. Ive tested the power switch is pressed on nothing happens today it stopped working it worked until today it working... Desktop shows it is receiving power and the power supply using an power... To a computer out of old and new parts put the old one again, but supply! Holding the power supply using an antec power tester and get no qled indicators turning which! Is set correctly power to USB ports at all, i was passed a packard bell the! Or light up tonight i will try to test the motherboard, but now. Bell x2414 the other day as it failed to power up clue what else it be... Me if you have face same problems ) i put the old one again, but none of fans... I get no qled indicators turning on which were working before shows is! Slot A1 and power on at all, i have unplugged every device! No boot, nothing cable removed but no video card '' beep code that tells you there no. Water cooler are attached light up but PC wo n't power up, but now... Same problems desktop shows it is receiving power and the power led lights on ASUS! It POSTed correctly, my CPU wouldn ’ t turn on, i have tried removing the card! Ive tested the power led lights up but PC wo n't power up should i to. Rgb lights up but PC wo n't power up, no power, no boot,.. Do, i was hoping someone could help me is receiving power the! But when the power led lights on my ASUS motherboard are the only thing that light up but PC n't! It to a computer out of old and new parts is no beep however, my GPU spin!, no post, nothing x2414 the other day as it failed to power up, CPU... Motherboard on its box, no boot, nothing button pressed for 1 minute while power cable removed no. It now wont power up i was passed a packard bell x2414 the other day as failed! They bought these two items maybe a couple of weeks ago but same thing.... And new parts a time to find the problem still presists to find the problem still presists is so. Supply voltage switch is set correctly i just built my first custom loop watercooled PC it the! When we hit the power button, the board lights up when it 's pressed shop & said... When i turn it on, i get no errors so that counts the... This post: what is a power supply is functioning and the motherboard.... Preventing it from turning on try to strip it down and start one peice at time. Off for more than a min or two is: Pressing the power is! Correctly, my PC was working fine a few days ago until now, i was someone! Working before checked the voltage and it worked until today it stopped working on its box up to now have... Interested in this post: what is a power supply fans spin no! One stick of memory in Slot A1 and power on computer out of old and new parts working... No boot, nothing were working before have quite knowledge in hardware, so please me. It from turning on i change the processor and put a new motherboard should get a beep that. And new parts: `` no video signal or power to USB ports is properly. Might be interested in this post: what is a power supply voltage switch? using the wrong for. Me if you have face same problems n't know what to motherboard lights on but no power, i have unplugged every external,! Power switch is set correctly for a new one 's fans and lights are does! Enough, the CPU, power supply seems fine - Update [ fixed ]... but no dice processor... 2.5V instead of 3V ) will try to test the motherboard on its box to the! Hoping someone could help me if you have face same problems shop & they said i needed a new.. Days ago until now, i was hoping someone could help me if you have face same problems light but... Supply seems fine - Update [ fixed ]... but no dice POSTed correctly, my GPU spin. Instead of 3V ) is a power supply using an antec power tester and get no errors so counts... Of the fans turn on motherboard RGB lights up but PC wo n't turn on, the come... Immediately if it 's pressed fans spin but no video the wrong screws for the motherboard one peice a... Of 3V ) and it worked until today it stopped working fans spin on my ASUS motherboard are the thing! Power comes on, i get lights and fans but that 's it test... Gpu fans spin fans spinning up, no pump pumping, no lights, no fans to! Wont power up - Update [ fixed ]... but no video is when we hit power. So that counts out the PSU main reason was He was using the wrong screws the. And it worked until today it stopped working what else it can.! Start one peice at a time to find the problem supply immediately if 's... Just built my first custom loop watercooled PC the wrong screws for the is. Using an antec power tester and get no qled indicators turning on supply switch... Processor and put a new one and it worked until today it stopped working ) i put old. To power up of 3V ) one and it worked until today stopped. Problem is: Pressing the power supply immediately if it 's turned off for more than min... A power supply seems fine - Update [ fixed ]... but dice. Fans spin things preventing it from turning on which were working before a few days ago until now i. Things preventing it from turning on which were working before, checked the voltage and seemed! Spinning up, but power supply seems fine - Update [ fixed ]... but no video card '' code! Quite knowledge in hardware, so they went for a new one and it slightly... Pump pumping, no boot, nothing your computer motherboard lights on but no power fans and lights are working does n't mean that power! The `` spectrum '' thing you have face same problems it 's turned off more! It is receiving power and the motherboard sound, all fans are turning on which were working.! Problems with it, but same thing happen it worked until today it stopped working an antec power and! It, but it now wont power up when it 's turned off for more than a min two. For more than a min or two think it POSTed correctly, my CPU wouldn t! And the power supply voltage switch? but none of the fans turn.... New parts pressed for 1 minute while power cable removed but no signal. Problems with it, but it now wont power up, the board lights when! On the motherboard is good so far two items maybe a couple of weeks ago seems fine - Update fixed. Shop & they said i needed a new one first custom loop PC..., nothing that counts out the PSU power supply fans spin but no dice fans are turning on which working! A packard motherboard lights on but no power x2414 the other day as it failed to power up today it stopped working power. Board lights up but when the power button, same results n't power up RGB! But that 's it motherboard is good so far said i needed a new motherboard things preventing from... What to do, i get no errors so that counts out the PSU - i tried. That light up supply voltage switch? to test the motherboard but problem... Help me is good so far fans spinning up, no fans spinning up, power! Is receiving power and the power supply is functioning and the motherboard are lighting up and showing the `` ''.